Перейти к содержимому


Отображение В Браузерах


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 14

#1 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 23 Декабрь 2012 - 21:48

Просматривал как отображается магазин в различных браузерах , вот что выявилось :

Сам работаю на Crome , тут все хорошо но вот

в Safari и в Yandex когда заходишь в раздел видео отзывы , наводишь мышь на меню каталога товаров  , то всплывающее подменю отображается как бы под видео

в Explorer вообще беда какая то , все криво :wacko:, слайдер без ссылок отображается, отзывы и предложения (слева вверху) виджет не выходит , а переходит на сайт ресурса,товары отображаются списком , а не таблицей.

В общем вот это выявилось, подумал, может настройки браузера у меня "кривые" , но нет , прошел по другим адресам и сайтам , там все отображается корректно.  

В Opera не смотрел , не установлен данный браузер.


Помогите пожалуйста поправить это....


Изображение





Изображение





Изображение

#2 Koderhan

Koderhan

    Активный участник

  • Модератоpы
  • 6 227 сообщений

Отправлено 24 Декабрь 2012 - 10:40

При внесение изменений в шаблоны давольно трудно соблюдать кросбраузерность. Иногда приходится жертвовать некоторыми визуальными изысками для простаты объяснения.
Например Internet Explorer не поддерживает закругление углов через свойство css3 , border-radius.
Это можно исправить только  загрузив 4 изображения для с закругленными углами. Данные действия требуют большого количества времени для реализации и дополнительные картинки будут создавать нагрузку, хоть и не большую но нагрузку на все браузеры. Даже на те которые поддерживают border-radius.
Если исправить не корректное отображение в IE то это скорей всего повлияет на корректное отображение в других браузерах. Еще важно какая версия IE, Чистый шаблон "Техника" рассчитан на корректное отображение в IE начиная с версии 7.

#3 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 24 Декабрь 2012 - 10:54

по картинкам ясно , благодарю,

а вот по поводу отображения товаров списком и выпадающего подменю меню?!

может здесь можно что поправить!?

Выпадающее подменю так отображается и в в Safari и в Yandex

#4 Vaccina

Vaccina

    Активный участник

  • Модераторы
  • 23 691 сообщений

Отправлено 24 Декабрь 2012 - 22:20

Для меню можно попробовать изменить z-index
В файле стилей main.css раздела редактора тем - добавьте

.menu_main {
  position:relative;
  z-index: 100;
}

Цитата

а вот по поводу отображения товаров списком

Пожалуйста, объясните по подробнее - что не так с отображением товара в режиме отображения списком.

#5 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 05 Январь 2013 - 23:23

Тут заметил такую деталь , недавно поднимал логотип повыше , как только поднял , так сразу в Explorer картинки еще больше поплыли!

Видимо это не корректное отображение из-за поднятия наверх картинок. Неужели нельзя регулировать расположение картинок без вреда общей стилистики?!

#6 Vaccina

Vaccina

    Активный участник

  • Модераторы
  • 23 691 сообщений

Отправлено 08 Январь 2013 - 23:30

Пожалуйста, приведите пример подобного поведения. Иногда IE может странно реагировать на изменение стилей. Возможно было не корректно задано значение или нарушена общая стилистика которую IE не может исправить.

#7 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 16 Январь 2013 - 10:56

Восстановили шаблон , ничего в кодах не трогали и посмотрели через IE на сайт , так же картинка растянута почему то, смотрел другие сайты с шаблоном техника , там все нормально показывает.

Помогите пожалуйста разобраться, в чем же все таки может быть дело.

Мне помнится Мы поднимали товары вверх на главной когда слайдер устанавливали.

Что интересно левый блок отображается нормально , а вот правый блок товаров растянут

Изображение


#8 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 16 Январь 2013 - 22:58

вот как выглядит сайт через IE , после того как мы переустановили шаблон по умолчанию,

Изображение


#9 Vaccina

Vaccina

    Активный участник

  • Модераторы
  • 23 691 сообщений

Отправлено 17 Январь 2013 - 00:15

Проверила ваш сайт в IE начиная с 8й версии - отображение корректное такое же как и в firefox. Сжатие изображений не наблюдаю. Попробуйте удалить в вашем шаблоне "HTML" следующую строку

<meta http-equiv="X-UA-Compatible" content="IE=7" />


#10 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 20 Январь 2013 - 09:46

да, стало гораздо лучше, но не на главной , а в других разделах, там корректно стало отображаться,  это Радует, в общем сказать сейчас только картинки на главной не корректно отображаются, в остальном все норм , благодарю Вас :)

#11 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 20 Январь 2013 - 09:56

вы знаете , что еще заметил , мы устанавливали картинки в разделы сайта и чтобы подогнать размер просто уменьшали в редакторе , на хроме все корректно , а вот EI они не уменьшились , может это наведет на ошибку?!

#12 miyako

miyako

    Активный участник

  • Модератоpы
  • 5 372 сообщений

Отправлено 20 Январь 2013 - 11:42

Просмотр сообщенияemin808 (20 Январь 2013 - 09:56) писал:

вы знаете , что еще заметил , мы устанавливали картинки в разделы сайта и чтобы подогнать размер просто уменьшали в редакторе , на хроме все корректно , а вот EI они не уменьшились , может это наведет на ошибку?!

В код,  где вы устанавливали картинки, то есть:
<strong><img src="http://asfn.storeland.ru/web/upload/assets/images/154/153295/23.png?9714" width="10" height="10" alt="">&nbsp;Шаг 1&nbsp;</strong>
Попробуйте прописать в чем измеряются ширина и длина:
<strong><img src="http://asfn.storeland.ru/web/upload/assets/images/154/153295/23.png?9714" width="10px" height="10px" alt="">&nbsp;Шаг 1&nbsp;</strong>


#13 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 19 Февраль 2013 - 07:18

пере устанавливали шаблон, сейчас в IE вообще не показывает сайт , с чем это может быть связано , помогите пожалуйста,

изменений ни каких серьезных не вносили, так же пробовали стандартный шаблон восстановить, так же отображается

Изображение

#14 support

support

    Активный участник

  • Модераторы
  • 3 683 сообщений
  • ГородМосква

Отправлено 19 Февраль 2013 - 11:48

Спасибо, что написали. Ошибку мы уже исправили. В благодарность за её нахождение баланс вашего магазина пополнили на 500 рублей.

#15 emin808

emin808

    Активный участник

  • Пользователи
  • PipPipPipPip
  • 538 сообщений

Отправлено 19 Февраль 2013 - 11:57

Да, оч приятно <_< благодарю Вас в ответ :)




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных